This article is also available in:
Bricksite supports a wide range of system configurations. But at some point your device will be too old to qualify for software updates. Due to constant changes in the technology, at some point functionality will stop working on obsolete devices. You can check if your operating system is obsolete in THIS LIST.

We recommend that you keep your software updated, but it is still possible to use certain older versions, see below.

Supported Operating Systems

Windows 8.1 ≤
macOS 10.15 (Catalina) ≤
Linux Ubuntu 18.04 LTS ≤
Chrome OS (until Auto Update Expiration Date)

Browser Support

Google Chrome 88 ≤
Mozilla Firefox 91 ≤
Microsoft Edge 88 ≤
Opera 74 ≤
Apple Safari 14 ≤

Mobile Support

Editing from phones and tablets via a mobile browser is not supported at all, because they do not support hover actions. Naturally, the website may be viewed on the following mobile operating systems.

Android 8.1 (Oreo) ≤
iOS 10 ≤

Supported Mail Clients

Outlook 2019 ≤
Apple Mail 13.4 ≤
Thunderbird 90 ≤

As a rule of thumb you may use any mail client that supports TLS 1.2 ≤.
Note that almost no email clients on the market support international email adresses with special characters, such as the Danish æøå. In these cases we must refer you to our online webmail.
Was this article helpful?
Cancel
Thank you!